Question

How to make my spaces PUBLIC

I can’t see permission option for spaces root or sub folders like FILES. I Want to make it public as a whole. please help

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It turns out DO buckets are fully compatible with S3, down to the bucket policy level. I was able to follow this guide: https://docs.aws.amazon.com/AmazonS3/latest/userguide/WebsiteAccessPermissionsReqd.html

Specifically, setting the bucket policy to allow public access worked. Here is the command I used with the AWS CLI:

aws --endpoint-url=https://nyc3.digitaloceanspaces.com s3api put-bucket-policy --bucket=<BUCKET> --policy file://policy.json

policy.json

{
    "Version": "2012-10-17",
    "Statement": [
        {
            "Sid": "PublicReadGetObject",
            "Effect": "Allow",
            "Principal": "*",
            "Action": [
                "s3:GetObject"
            ],
            "Resource": [
                "arn:aws:s3:::<BUCKET>/*"
            ]
        }
    ]
}

I got the same issue. How to automatically set new uploaded files as PUBLIC?

+1 An upload into a directory that has public ACL does not inherit such settings.