Question

.....

Posted February 26, 2014 1.8k views
Hi there. I use centos 6 with nginx When I try to mount a file that weighs more than 2M - Can not. I went to etc / php.ini and tried to change the lines upload_max_filesize = 2M post_max_filesize = 2M But nothing works, what can you do? Reset NGINX + MYSQLD

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
3 answers
What's with the title?

Hello,

You can create a php info file in order to check the current values and check which is the php.ini file in use. Create the following file in your public_hmtl folder - phpinfo.php and put the following code inside it:

<?php
phpinfo();
?>

You can also use the following command in order to find the location of the php.ini file:

php -i | grep php.ini

The output will be:

Configuration File (php.ini) Path => /etc/php/7.2/cli
Loaded Configuration File => /etc/php/7.2/cli/php.ini

Then check for the current value of uploadmaxfilesize you can also check which is the configuration file - php.ini that is currently used and apply the changes there (if the site using the global php.ini file and you change the values for these settings this will make the changes globally for all sites). Ideally you would like to have the following values:

upload_max_filesize = 64M
post_max_filesize = 64M

You also need to restart your web server in order the changes to take effect.

Hope that this helps!
Regards,
Alex

Submit an Answer