Question

2 wordpress installs under same domain with nginx

  • Posted on August 1, 2014
  • mzukerAsked by M Zuker

Hello, all works for a single install. But we have 2 different wordpress installs under the same domain. How to setup this for www.site.com and another wordpress in www.site.com/other

What to change?, where?, because now only works the main install. The rest give me 404 error.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

If you could explain a little more about what you’ve already tried, it makes it easier for people help track down your problem.

Assuming you followed this tutorial, the first change is to make sure that you create a seperate database and datbase user for both sites. Make sure you also use the right ones in each site’s wp-config.php file.

Assuming that the root blog is installed in /var/www/html and the sub-blog is installed to /var/www/html/subdirectory, edit your /etc/nginx/sites-enabled/wordpress file to look like:

server {
        listen 80 default_server;
        listen [::]:80 default_server ipv6only=on;

        root /var/www/html;
        index index.php index.html index.htm;

        server_name your_domain.com;

        location / {
                try_files $uri $uri/ /index.php?q=$uri&$args;
        }

        location /subdirectory {
                try_files $uri $uri/  /subdirectory/index.php?q=$uri&$args;
        }

        error_page 404 /404.html;

        error_page 500 502 503 504 /50x.html;
        location = /50x.html {
                root /usr/share/nginx/html;
        }

        location ~ \.php$ {
                try_files $uri =404;
                fastcgi_split_path_info ^(.+\.php)(/.+)$;
                fastcgi_pass unix:/var/run/php5-fpm.sock;
                fastcgi_index index.php;
                include fastcgi_params;
        }
}

You should be all set to go. If you run into any issues, let us know!

Andrew you got it, you are the BEST! Thank you !!!