Question

403 Forbidden in nginx/1.12.0 after Install SSL (CentOS6)

I’m install Wordpress in CentOS 6 (Nginx) After installed SSL Certificat I stumble In error 403 Forbidden nginx/1.12.0 ?

/etc/nginx/Conf.d/ssl.conf

HTTPS server

server { listen 443; server_name Sitename.com www.Sitename.com;

ssl on; ssl_certificate /etc/ssl/server_chain.crt; ssl_certificate_key /etc/nginx/ssl/server.key;

access_log /var/log/nginx/nginx.vhost.access.log; error_log /var/log/nginx/nginx.vhost.error.log;

location / {

root /var/www/; index index.html; }

}

Please Help Me ?

Subscribe
Share

@Mehdifaik

First let me advice you to learn markdown, it makes your questions more readable and better to understand.

Check this markdown cheatsheet for help https://github.com/adam-p/markdown-here/wiki/Markdown-Cheatsheet


Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Hi @Mehdifaik

Can you please post your server block configuration, which should be located in /etc/nginx/sites-enabled/. You can replace your domain with domain.com if you want. Are you using Let’s Encrypt for SSL or some other certificate provider?

Problem in /etc/nginx/Conf.d/ssl.conf When you change

location / {

root /var/www/;
index index.html;
}

}

to

location / {

root /var/www/**html**;
index index.**php**;
}


}

The page loads as file for download (/var/www/html/index.php)

@Mehdifaik

Post the output of error log, use this command to get the last 20 lines:

tail -20 /var/log/nginx/error.log

So we can help you.