Question

404 error – apache updated, but still does not work/

Posted September 30, 2019 365 views
ApacheDigitalOcean

Hello, my name is Anna, nice to meet you all!

I installed apache on my droplet, so I could see my web page, but it doesn’t work. I always have 404 error.
So I changed apache2 config like that:
<Directory />
Options FollowSymLinks
AllowOverride All
Require all denied
</Directory>

<Directory /usr/share>
AllowOverride All
Require all granted
</Directory>

<Directory /var/www/>
Options Indexes FollowSymLinks
AllowOverride All
Require all granted
</Directory>

<Directory /srv/>

Options Indexes FollowSymLinks

AllowOverride All

Require all granted

</Directory>

And it didn’t help at all:)
My IP’s 159.65.252.195, do you guys have any idea how to fix this?

Thanks a lot!

PS I’m just learning, so I’m sorry if my question is stupid.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @anutkyns,

You’ll need a separate configuration file for the domain you wish to use.

I’ll recommend you to check the following Digital Oceaon’s article - HERE

Once you’ve followed through, you’ll have a pretty good base of knowledge to work with Apache.

Kind regards,
Kalin

Submit an Answer