Question

404 not found after changing permalinks to post name in wordpress

Posted August 18, 2014 12.8k views

Clean default wordpress installation, all fine, just when I change permalinks in wordpress settings to post name, the default wordpress post is given 404 not found. Any help would be appreciated.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
5 answers

Ok, found the solution,

<Directory /path/to/site>
     #add the following setting to allow .htaccess in your web dir to work
     AllowOverride All

     #other settings ---

</Directory>

and thats in the /etc/apache2/apache2.conf file

  • I have the same problem.

    Unfortunately, the solution you found didn’t work for me.

    Terrible experience with this DO “1-click” install. I think it would be faster if I had created a clean CentOS and done everything myself… nothing works: permissions, rewrite, etc.

  • This solution works for me, just don’t forget restart the apache service service apache2 restart

and mod_rewrite is enabled…

this is unbelievable ! I just dont have the solution, anybody please help !!
My .htaccess

# BEGIN WordPress
<IfModule mod_rewrite.c>
Options +FollowSymlinks
RewriteEngine On
RewriteBase /
RewriteRule ^index\.php$ - [L]
RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteRule . /index.php [L]
</IfModule>

# END WordPress

rewrite_module is on

and still 404....

same her how to solve this problem

be sure to add mod_rewrite and restart apache after that

sudo a2enmod rewrite

sudo service apache2 restart

Submit an Answer