Question

502 bad gateway after root password reset

After reseting the password the wordpress site went offline with error 502, the nginx log error indicates that

"listen () to [::] :80, backlog 511 failed (98: adress already in use) "

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Looks like port 80 is not released by whichever process was running earlier.

So, kill that process with:

sudo fuser -k 80/tcp

Then restart Nginx.

Curiously I’ve seen this “backlog 511” error in Plesk. Do you use Plesk? If so, switch off and on Nginx by going to Tools & Settings > Services Management.

If that didn’t work, tell us exactly what password you changed.