Question

502 Bad Gateway nginx/1.1.19 Joomla 3.x

  • Posted on November 8, 2013
  • gfxAsked by gfx

Hi there Anybody know how to get Joomla running properly on NGINX and Ubuntu setup. I followed the instructions on digital ocean somewhere to get mysql, phpmyadmin, php etc. up and running via command line All of that looks fine, but when I try to log into Joomla front or backend, I get this page:

<html> <head><title>502 Bad Gateway</title></head> <body bgcolor=“white”> <center><h1>502 Bad Gateway</h1></center> <hr><center>nginx/1.1.19</center> </body> </html>

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I guess this a Nginx related configuration issue. you can solve this by adding two lines into configuration file. <br> <br>edit Nginx configuration file /etc/nginx/nginx.conf : <br> <br>> nano /etc/nginx/nginx.conf <br> <br>add two lines below: <br> <br>http { <br> … <br> fastcgi_buffers 8 16k; <br> fastcgi_buffer_size 32k; <br> … <br>} <br>save the file and restart the service: <br> <br>>service nginx restart <br> <br>this should solve your problem.

What’s the output of: <br><pre>sudo service nginx status</pre>