502 invalid gateway., AKA "What are the valid correct settings for gitlab docker registry in DO spaces, for omnibus gitlab? "

Using the instructions here, I was trying to put my docker registry in s3 storage. The registry tries to go to AWS by default, eventually I figured out what to do, so in case there’re some other lost souls out there trying to do the same thing and having no luck, here’s the solution

I put the ruby snippet in my

registry['storage'] = {
    's3' => {
        'accesskey' => 's3-access-key',
        'secretkey' => 's3-secret-key-for-access-key',
        'bucket' => 'docker-registry',
        'region' => 'ams3',
Didn't work

2018-10-09_17:13:03.86623 /var/cache/omnibus/src/registry/src/ +0x2d 2018-10-09_17:13:04.89556 panic: Invalid region provided: ams3

How do I convince it to go to DO? I tried to use the setting from the DO backup documentation

I found some additional information here, so I tried

‘regionendpoint’ => ‘

Now I get a 503

Another bit of research brings me here Full snippet now looks like

registry[‘health_storagedriver_enabled’] = false registry[‘storage’] = { ‘s3’ => { ‘accesskey’ => ‘s3-access-key’, ‘secretkey’ => ‘s3-secret-key-for-access-key’, ‘bucket’ => ‘docker-registry’, ‘region’ => ‘ams3’, ‘regionendpoint’ => ‘’ } }


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer