I left my laptop three days ago. I don’t change anything on my server, even don’t access it. And My website gets 504 bad gateway today. What the hell?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

To help, we’ll need more info:

Apache2, or NGINX?

Either way, you’ll need to hop on the server, and grab logs from your web daemons log files (/var/log/apache2 for Ubuntu/Debian Apache2, /var/log/httpd for CentOS/Fedora Apache2, and /var/log/nginx/ for NGINX)

Once you have the logs, look for errors. They will tell you why the site is failing. If unsure, post the logs (just the errors) here.

  • Hi
    Thank for your replying!
    I’m using Nginx. Here is my log

    2016/04/29 10:13:57 [error] 3930#0: *45670 open() "/home/www/support.wiloke.com/public_html/favicon.ico" failed (2: No such file or directory), client: 139.255.188.166, server: support.wiloke.com, request: "GET /favicon.ico HTTP/1.1", host: "support.wiloke.com", referrer: "http://support.wiloke.com/"
    2016/04/29 10:13:58 [error] 3930#0: *46516 open() "/home/www/support.wiloke.com/public_html/favicon.ico" failed (2: No such file or directory), client: 162.243.163.178, server: support.wiloke.com, request: "GET /favicon.ico HTTP/1.1", host: "support.wiloke.com"
    2016/04/29 10:32:51 [error] 3930#0: *56100 upstream timed out (110: Connection timed out) while connecting to upstream, client: 141.8.142.24, server: support.wiloke.com, request: "GET /viewtopic.php?f=10&t=206 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "support.wiloke.com"
    2016/04/29 10:33:51 [error] 3930#0: *56601 upstream timed out (110: Connection timed out) while connecting to upstream, client: 141.8.132.98, server: support.wiloke.com, request: "GET /viewtopic.php?f=10&t=206 HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "support.wiloke.com"
    2016/04/29 10:43:43 [error] 3930#0: *62211 upstream timed out (110: Connection timed out) while reading response header from upstream, client: 60.219.236.106, server: 178.62.223.251, request: "POST / HTTP/1.1", upstream: "fastcgi://127.0.0.1:9000", host: "45.55.19.38:80"
    
Submit an Answer