6 months later I still cant get droplets to work

Its been 6 months now and I still cant get a droplet to work.

Its exactly the same issue. The domain will not link to the folder and I cant ftp to it.

I have given up being angry. Another 8 hours lost.

The support here is minimal to be honest. The comments are all the same.

Im actually quite an expert now at many things, OTHER THAN GETTING MY DROPLET TO WORK.

It makes me want to cry seeing other people asking more advanced questions because clearly they have have got past that stage.

Im wondering if theres a magic button to stop people like me using it. I have been following the instructions to the letter time and time again.

Here is my latest Virtual Host file:

<VirtualHost *:80> # The ServerName directive sets the request scheme, hostname and port that # the server uses to identify itself. This is used when creating # redirection URLs. In the context of virtual hosts, the ServerName # specifies what hostname must appear in the request’s Host: header to # match this virtual host. For the default virtual host (this file) this # value is not decisive as it is used as a last resort host regardless. # However, you must set it for any further virtual host explicitly. #ServerName

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/

    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf


The documetn root exists with the index file and I have enabled it:

sudo a2ensite

and restarted apache:

sudo service apache2 restart

The thing is, i have done this now about 15 times over 6 months with two totally seperate droplets.

I also know that writing these questions achieves nothing. And from experience my question will be deleted as obviously people that cant get past the first stage dont belong here.


Oh theres a laugh YOU HAVE TO SELECT A TAG TO POST THIS QUESTION AND YET NONE OF THE TAGS MAE ANY SENSE. I mean… what tag do I use for I Cant Get THe Droplet to work? DNS? no, VPN? i dont think so. I think i’ll try Configuration Management which doesnt make any sense but I cant post unless I choose one. I wonder how many questions have Ansible as the tag.

Last time I submitted a ticket the dude replied ARE YOU STILL TRYING TO GET IT TO WORK and then linked to a walkthrough on installing Apache, which I have clearly dont a number of times. No help there then.


Farther than I got, I can’t even log in!

I dont want to say I told you so but ive done it all.

I knew it was easy. I loaded the droplet up, took an old bike, a broken fence post and 4 tree branches to the dump. I know that was about 3.45pm as I wanted to deposit several huge cheques that I got for setting up servers etc and then came home and watered the garden and then pressed all the right buttons on the keyboard and now, 5.30 its working, I can ftp with Dreamweaver and the www.domain and domain are together!!

Its incredible. Essentially I was pressing all the wrong buttons and then when I pressed the right ones it all worked.

I think setting up the A name record www thing helped in the Droplet DNS configuation setting but thats not on any of the walkthroughs. I had to applied my 27 years experience of faffing about with DNS settings to figure that out myself. So i give myself all the credit for solving this 6 month problem.

I can now go to my other Droplet and do that same thing. Ive felt like the kid that diddled in the pool for 6 months saying that I was still trying to figure it out and its ‘not simple’ and its ‘pretty complicated’ etc. and all along, all I had to do was press the right buttons on the keyboard.

I also brought some new shoes today and I cant rule that out in factoring into this somehow.

So now im a hardcore server person, hoot hoot.

You can all marvel as nothign happening by refreshing 4 million times between now and dawn, ie 13 hours time. F5 is the shinyest button on my keyword. The spave bar is shiny too as well as the enter button and all the letters etc, but F4 and F6 are all gooky.

I have just destroyed my droplet a few times and am now wondering if I get charged $5 everytime I start over? I’d like my $5 back please if possible. I think im on my 3rd or 4th droplet.

I have also set up another domain and note that a A name www does not automatically get set. Maybe thats what the problem was all along.

I’ll see as im installing the LAMP AGAIN right now.

I understand what you are saying, but the point is that I am a highly skilled programmer. Im quite capable of doing this. The point is the walk throughs simply dont work. I can practically install LAMP blind fold now and set up the virtual servers.

As far as im concerned the two items are central to making this work. Pointing www.domain to domain and getting ftp to work. Its that simple. And yet it simply doesnt work. I can kill my droplet, do a clean LAMP install. i dont even need mySQL and PHP and demonstrate that I cant log in via Dreamweaver, the most popular and common web design tool in the world.

I would have thought a walk through on that would be a no brainers.

Things on my ‘to do list’ LISTENERS, HOSTS, cloud.config, and a few other things including the apache config file. I have basically looked at everything and one thing is common NOTHING get to resolve to ANYTHING.

I have removed the domain I was using and will be using another. My strategy was to install LAMP and then virtualmin but even that DIDNT WORK - NOTHING will get the to point to

Personally I do suspect that its what I call a microsoft break, a feature I use to describe something that has a deliberate error to to stop people using it. I picked that up particularly with MSSQL R2 etal that also just dont work, but at least they say in the small print that its designed to not work, ie import ANY OTHER databases. Anyway. I’ll not give up, but beleive me, I have the skills to do it, I just dont have the time which is the limiting fact. Obviously I cant do it at the moment, but thats because every walk through doesnt work. As inferred I can do the LAMP stack in about 20 minutes with my eyes closed. I can install phpmysql and set it up and configure it and get an entire website up and running ON THE DOMAIN.COM but not the www.

This is just so fundemental.

I run about 5 other VPS’s other than cloufVPS in Holland they are all nightmares. CloudVPS use Direct Admin which is super simple. VirtualMin I ghave concluded DOES NOT POINT to domain.,com.


It sounds like you should do one of two things:

  • hire someone with the skills to walk you through what is going on
  • move to a managed hosting so you dont have to worry about any of this

I am honestly not being smarmy. I can understand your frustration. It takes some time to learn (and fully grasp) all the things needed to run a web-server. If you are genuinely interested in running your own server, stick with it! You will get there.

  • Ask questions in the forum, even if they sound stupid. The DO forum has been a decent place to get help. Most everyone will try to get you there.
  • Offer some payment for someone to spend a few hours walking you through a basic setup

If you have reached your limit, you might be better off with a hosting company that does all of this for you.

I do not work for DigitalOcean, just so you know.

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I just got a message saying someone else replied but I cant find the reply.

However. I would like to say that I gave up on all that. I found the best way to do it was create a droplet and then just sudo install virtual min. There are a few steps, but unlike all the steps above for a LAMP setup, these work with repeatability. I still dont really understand it all but I can get things done.

yes, digitalocean is wtf suck . not clever support , i got really confuse about their weird roles about droplet . yeah , your price is represent your quality . cheap but too risk to place your main business in digitalocean . i never face weird problem in AWS , will back again to AWS for better service and support .

I think the problem with digital ocean and other companies is that the way the advertise can be misleading for regular users I mean yes, you can “Deploy an SSD cloud server in 55 seconds.” but it is not that simple. When you get an unmanaged VPS, it is an assumption that you have the knowledge on how to set up a server and maintain it. Maybe next time hire a freelancer who has experience with Digital Ocean. It saves you time.

It’s difficult to guess what the problem is but maybe you should also check your DNS records to make sure that you have an entry in those for www.

I have tried virtualmin multiple times. It still doesnt point www.domain to

Postbox, have a look at they do a (free) control panel that will install all the things you need and set them up for you here on your DO VPS. It’s best to start with it on a fresh server. Once you have that installed you should be able to quite easily run your server and do all the things you want, and learn in the process. The forums there used to be generally very friendly and helpful too, and probably still are.

No need to cry, or go mad with frustration. A lot of people start with scripts and control panels, they just don’t like to admit it. ;)

Once you have that (or any other control panel) installed, the first thing to do then is read some ‘How to secure your server’ articles and guides, there are some here on DO.

Then you’ll be all set. Also remember that absolutely everyone started somewhere and usually not as long ago as some would have you believe!

Digital Ocean with the ease of use and pricing is a great place to start. Go for it!

What I mean, just edit 000-default.conf so it send to default location.

Anyreplys before i die appreciated. but I wouldnt bother to be honest. It only takes 6 months to get no where at all, its hardly worth the effort.


Thats me done for for another week. I cant afford to hit my head against this any further.

My last efforts were to go VERY SLOWLY to install nothing other than LAMP with phpmysql

Im not touching anything else.


Cant log in via dreamweaver at all. Cant access ftp folder at all Cant point to web folder


Currently attempting to NOT user virtual server and just get it done without touching anything whatsoever but having trouble (HOW UNUSUAL) pointing the to the, which would be a start.

Wow, cant wait until this isnt mind bobblingly impossible.

no I totally cant connect via ftp. the other droplet connects. odd. It was connecting a while back.


I have some access via dreamweaver to the server, obviously not the right part and then suddently the settigns that were working just stopped working. Clearly I didnt do something that was wrong, I hate making mistakes like that, One i didnt tough someones token ring network and it stopped working and I spent 4 days fixing it. Oh look, not button to make a reply with. I’ll just pray this post to appear… maybe if i press RETURN, here goes No, that just adds a new line. I hate being rubbish at computers. You’d have thought after 14 years of programming id be able to add a post to a question thing.

Clearly the text box above is just a fake to fool stupid people with no computer expertise. This other box must be the one the clever people use.

I havent asnwered this question those so do I press Answer or just jump out the window? i cant decide.