Question

_acme-challenge record keeps disappearing.

Added record for Let’s Encrypt authentication.

_acme-challenge txt -------------------------

However, when I tried to renew, the record disappeared. I’m not sure, but it seems to disappear after a month or two after adding. At first I thought I deleted it by mistake, but it is already the second. What’s the problem?

Thank you in advance.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @siche,

It’s not supposed to stay there after you’ve been authenticated. I’ll recommend using certbot to issue and renew your Let’s Encrypt without having to manually add files in your acme-challenge folder.

If you are not sure how to do that, I’ll recommend checking out this article:

https://www.digitalocean.com/community/tutorials/how-to-secure-apache-with-let-s-encrypt-on-ubuntu-18-04

In this tutorial, you will use Certbot to obtain a free SSL certificate for Apache on Ubuntu 18.04 and set up your certificate to renew automatically.