Question

A file that doesn't exist is all I can see...

Setting up multiple WP sites using the tutorial: https://www.digitalocean.com/community/articles/how-to-set-up-apache-virtual-hosts-on-ubuntu-12-04-lts

All seemed to be going well: when I set up /var/www/eillelacheap.com/public_html I added an index.html that read:

New server This domain is now pointing at the new server.

Now I"ve uploaded my WP files and database and deleted the index.html (around an hour ago). However, it’s still showing up! I have set up no caching on the server, and have cleared my cache/used different browser/used different computer/my phone… I’m still getting this stupid index.html that was deleted AAAAGES ago.

I then created a new index.html that read “new index” (just incase it was a index.php issue). No change.

I’ve gone back and forth with support and they haven’t been able to diagnose it. I’ve grep’d around and can’t find anything on the server with that string. I can’t access any of the other files I’ve uploaded… It’s kind of like the server decided it really liked that index.html and doesn’t want to change.

I’m completely at a loss…


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

What’s the domain name? What’s the output of this command? <br> <br>“ls /var/www/eillelacheap.com” <br>Also, please pastebin your virtualhost config.

OK, I’ve now completely and utterly removed the files, run a2dissite on it, and removed all mention from sites-enabled, restarted apache and even restarted the server. <br> <br>The stupid file is still there… Looking at me. There’s no caching set up on the server, except what is standard for LAMP. I don’t understand how <br>a) It’s resolving to anything now that the hosts files are gone. <br>b) It’s resolving to a file that was deleted over 10 hours ago.

Thanks for the prompt reply. Yes, index.php is first in line on dir.conf and php-gd is installed. I have another WP site up and running on one domain, and another that’s accessible by IP address (DNS is still propagating)… But this one site just won’t react to any changes.