About :-How to install and use graphite on ubuntu 12.04

November 19, 2014 1.3k views

I face a problem :-
when type in terminal
sudo a2dissite 000-default
it comes site 000 already disabled and in web browser (i.e ubuntu ) no graphite screen is opened actually.Please help me in this problem .
Thanking You

1 comment
1 Answer

Without more information, it's hard to know where your problem is. How did you install Graphite?

This tutorial would be a good starting place for getting it up and running on Ubuntu 12.04:

by Justin Ellingwood
This tutorial will cover how to set up Graphite and Statsd on your server. Graphite is a graphing library that can be used to plot data-sets in a visually appealing way. Statsd is a program that can collect data on your system. When these programs are combined, you can generate useful graphs that describe the trends of your server.
  • As I am installing Graphite on Ubuntu 14.04 so I refer to this link
    and at last when I install and configure apache portion then sudo a2dissite 000-default
    this will not run properly and after that checking in web interface portion is not opened.

    Waiting for positive response

    by Justin Ellingwood
    Tracking statistics is a great way to make informed decisions about your systems, servers, and applications. Graphite is a graphing library that can be used to render customized graphs for any kind of data that is send to it. In this guide, we'll talk about how to install and use Graphite on an Ubuntu 14.04 server.
  • sudo a2dissite 000-default just disables the default Apache configuration. If it says that it is already disabled, then it shouldn't be a problem. What happens when you enable the Graphite's Apache configuration?

    sudo cp /usr/share/graphite-web/apache2-graphite.conf /etc/apache2/sites-available
    sudo a2ensite apache2-graphite
    sudo service apache2 reload
  • When sudo cp /usr/share/graphite-web/apache2-graphite.conf /etc/apache2/sites-available
    this runs ok.
    sudo a2ensite apache2-graphite
    after this command o/p is like this :-Site apache2-graphite already enabled
    sudo service apache2 reload after this command
    o/p is like Reloading web server apache2

    but in web interface nothing open actually it says internal error 500

Have another answer? Share your knowledge.