Access denied for user 'root'@'localhost' (using │ password: NO)

Posted May 22, 2016 6.9k views
UbuntuMySQLControl Panels

Hi guys
i have followed this tutorial to install ispconfig on my ubuntu 16.04 server


everything seemed good until this error
it says
Access denied for user ‘root’@'localhost’ (using │ password: NO)


what am i missing?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
2 answers

When logging into MySQL from console or SSH, you have to specify the -p flag. For example:
mysql -u root -p
You will be prompted for your MySQL password.