Question

Access denied using cURL from Droplet

So I’m trying to cURL a website from a Droplet, but I’m getting this error:

<HTML><HEAD>
<TITLE>Access Denied</TITLE>
</HEAD><BODY>
<H1>Access Denied</H1>
 
You don't have permission to access "http&#58;&#47;&#47;www&#46;kroger&#46;com&#47;" on this server.<P>
Reference&#32;&#35;18&#46;3f9a18b8&#46;1616192985&#46;122eaf1
</BODY>
</HTML>

I tried this on my local machine and it works just fine. I also tried to run this on a fresh Droplet, but I’m receiving the same error message. Are websites just blocking Digital Ocean Droplet connections? If not, what can I do to fix this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

It looks like that there is a deny rule on the kroger .com side that is blocking your HTTP requests. It is possible that they have a geo IP check and they could be blocking access to their services from specific countries.

What I could suggest in this case is getting in touch with the kroger .com provider and asking them to allow your Droplet IP address to access their services.

Regards, Bobby