Accidental uninstall

April 23, 2014 728 views
Hey, Whilst trying to do some updates on my CentOS server the other day I accidentally removed the package NSS-SoftOkn-freebl. This stopped yum from working so I couldn't reinstall it (I also tried installing a straight RPM, but couldn't get that to work either). So after a while of failing I rebooted the machine only to find that now I can't login, it sits stuck at the "{hostname} login:" terminal and nothing entered works. I've tried booting into recovery mode then mounting the file system, however even though I can do this I cannot then fix the issue as I can't seem to wget or run rpm etc. I know the majority of the problem is around not existing in /usr/lib64, however I can't even seem to get a temporary version in there so I can at-least boot up / log in and try and yum install a version again. Any help would be HUGELY appreciated as currently my only real last resort is to restore a snapshot from ~4 months ago :( Thanks in advance Chris
1 Answer
Unfortunately, there aren't all that many options as is needed for most programs that could be used to download something from the internet. Wget, curl, ect... aren't going to work. If you're lucky, you might have a copy of the rpm in /var/cache/yum/ Maybe by some chance you have a program installed that bundles its own copy. Try searching with "find / -iname"
Have another answer? Share your knowledge.