Question

Accidentally removed resolvconf package. How to get it back?

It’s always a bad idea to do smth before you have your morning coffee. Anyway, it already happened. Was configuring postfix to send emails via Google Apps, there was an issue with resolving domain names and no pings from the droplet. While reading some StackOveflow questions found an advice to reinstall resolvconf, but went into the process without reading the comments (dumb me, yes).

Package was purged, and reinstall isn’t possible as apt-get can’t resolve sources anymore. Restarted the server. Downloaded package directly via

wget http://91.189.91.13/ubuntu/pool/main/r/resolvconf/resolvconf_1.69ubuntu1_all.deb

and tried to install it

dpkg -i resolvconf_1.69ubuntu1_all.deb

Rebooted the server, but no changes. Running apt-get update fails to fecth sources:

...
W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/trusty-backports/Release.gpg  Could not resolve 'mirrors.digitalocean.com'
...

OS: Ubuntu 14.04 x32 Any ideas?

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Installing the package manually may have worked here. We are currently experiencing an issue that is causing problems reaching the Google public DNS servers configured by default on droplets.

While our team continues to work to resolve the issue, you can fix this on an individual droplet by updating the DNS servers it uses.

On Ubuntu, you can change the DNS servers temporarily by editing your /etc/resolv.conf file but this change will be overwritten the next time the droplet is rebooted.

For a permanent change, you can edit the /etc/resolvconf/resolv.conf.d/base file to include:

nameserver 208.67.222.222
nameserver 208.67.220.220

example using the OpenDNS.org servers.

Once you’ve made the changes you can update resolvconf by running

sudo resolvconf -u