Question

Active custom domain not working

Posted September 22, 2021 80 views
DNSDjangoDeploymentCDNDigitalOcean Droplets

Hi!

I firstly deployed my Django app on DO and then I tried to deploy it on a custom domain, therefore I firstly added my custom domain. I went to the registrar and changed the 3 Nameservers and then I waited until the custom domain’s status changed to ‘Active’ - it took about 30 mins. Whenever I access my app using app_name.ondigitalocean.app/, it works, but if I try to access it using my custom domain, it’s not showing anything apart from 'Index of’ page. Do you have any idea why is that? I mention that I’m new to hosting and this is my first time trying to host on a custom domain.

Screenshot here: https://imgur.com/KTKO5Oa

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
1 answer

Hi @feherdarius,

I’m sure you’ve done it already but can you confirm you’ve followed the Documentation on how to manage domains on the DigitalOcean App platform?

https://docs.digitalocean.com/products/app-platform/how-to/manage-domains/

Basically:

Add a Custom Domain
Go to https://cloud.digitalocean.com/apps, click on your app, and click on the Settings tab. Then, click the Edit link to the right of Domains, and the Add Domain button.

On the Add Domain form, enter your custom domain name at the top of the form in the text area under Domain or Subdomain Name, then click to proceed.

You are given a choice to delegate your DNS management to DigitalOcean or to point to your app by adding a CNAME record to your domain configuration.