when logged as admin admin-ajax.php working fine. if non-authenticated user access admin-ajax.php return 403.
I tried the following operation:

  • file permission changed
  • all the plugin uninstalled and installed.
  • .htaccess file regenerated.

The issue still not fixed. Does any other possibility fix these issues? where I found the uwf firewall access log?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
2 answers

Hello,

I’ve had a similar problem in the past and it was because of a caching plugin like W3 Total cache or similar. Basically minified JavaScript files could be causing the issue.

What I could suggest is to purge the cache and check for the permissions applied to cached files as well. Note that disabling the W3 total cache plugin does not delete the cached files.

Let me know how it goes!
Regards,
Bobby

Hi @bobbyiliev,

Thanks for your update. I have didn’t install any cache related plugin and security related plugin.

Thanks,
Mani

  • Hello,

    In this case maybe you have some special rules in your .htaccess file or your Apache virtual host, I would suggest trying with the default Wordpress .htaccess rules and see how it goes:

    # BEGIN WordPress
    
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    
    # END WordPress
    

    Another thing that might be causing the problem is an Apache module like mod-evasive for example. Could you run the following and check for any special modules like mod-security and mod-evasive:

    apachectl -M
    

    Also make sure to check your Apache error log for more information:

    tail -100 /var/log/apache2/error.log
    

    Regards,
    Bobby

Submit an Answer