Question

After creating a droplet and adding a domain i still get this same issue DNS_PROBE_FINISHED_NXDOMAIN

Posted September 17, 2020 179 views
DNS

After creating a droplet and adding a domain i still get this same issue DNSPROBEFINISHED_NXDOMAIN

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
4 answers

Hi @anthonyegbah,

You need to have a WebService like Nginx/Apache and add the domain there.

Pointing the DNS of your Domain to your Droplet is only the first step. You need to install a WebService, create a configuration file for your Domain there and then you’ll be able to see the domain on the droplet.

I’ll recommend checking out the following article in order to help you achieve that :

https://www.digitalocean.com/community/tutorials/how-to-install-linux-apache-mysql-php-lamp-stack-ubuntu-18-04

Now, please note the above article is for an Ubuntu server. If you are using CentOS for instance, you can check it’s equivalent in the Tutorial’s section.

Lastly, if you just want to make sure your A record is properly configured and the domain is pinging from your droplet, you can do a ping from your cmd/terminal :

ping domain.com

Regards,
KFSys

by Mark Drake
A "LAMP" stack is a group of open source software that is typically installed together to enable a server to host dynamic websites and web apps. This stack typically consists of the Linux operating system, the Apache web server, a MySQL database, and PHP, a dynamic content processor. This tutorial serves as a guide for installing these components on an Ubuntu 18.04 server.

In addition to the very good advice above, I wanted to share a link to the documentation for adding domains to the DigitalOcean Networking -> Domains service:

How to Add Domains

Additionally, if you did follow all these steps and your domain is configured properly, DNS cache can take up to 48 hours to clear. You could try using a different device (phone or laptop or friend’s computer) to test the domain for you to see if the problem is everywhere.

Any other additional details about what you’ve done / tried so far could also be helpful if you’re still stuck - good luck!

Hello, @anthonyegbah

As per baraboom’s reply all DNS changes might take up to 48 hours in order to fully update. This is due to ISP DNS cache and general DNS propagating as well. This usually happens a lot faster but will still take at least few hours to fully update.

You can check the DNS records with our DNS tool: https://www.digitalocean.com/community/tools/dns.

You can also monitor the DNS propagation using this site: https://www.whatsmydns.net/

It will show you a DNS record check from various points around the world. This will help you to see if there is a DNS misconfiguration or if it’s just the DNS slowly updating.

Hope this helps!
Regards,
Alex

follow alexda S way i checked it

Submit an Answer