Question

After disabling root login, make sure you can SSH to your Droplet as the deploy user and use sudo

Hi there

Warning: After disabling root login, make sure you can SSH to your Droplet as the deploy user and use sudo for this user before closing the root SSH session you opened to make these changes."

am not only new but also a newbie; Now I missed this warning! Have finished setup before I saw it. “Deploying rails on ubuntu 10.04 with capistrano, Nginx, and puma” is the way I want to go with my droplet. So has anyone got a way around this warning? My supperuser is not “deploy”. I made another superuser, “deploy” but can’t log in with it; also can’t ssh to droplet with it. Help will be appreciated!

Subscribe
Share

Submit an answer
You can type!ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I have added a chat plugin to a site I haven’t really setup yet and was just using for testing purposes, to help walk you through… give me a shout when you’re ready, you can find me at XXXXXXXXXXXXXXXXX

Thanks… I’ve removed my domain name now.

i got it already

I am online and waiting for you whenever you’re ready… I left my domain name in the above reply, but I’ll delete it if you confirm that you have it already :)

  1. I started by using the DO console, so unstable I ran away to terminals on my local machines. That’s where I did the initial set up, installed LAMP, ruby and uninstall ruby when I realised deploying according to this tutorial is better for me. Currently I can’t get to shh log in on any of my local machines - I always get “permission denied ().” after 3 “incorrect password” but when I ftp:mydomain on my local machine, I do get in using the same password that ssh login says it’s incorrect.; So I got stuck and came back to DO console and that’s been a nightmare - unstable, unresponsive that I have not been able to do anything for past 24 hours.
  2. I will try PuTTY.
  3. I’m not confident that I have a public/private key pairing correctly.
  4. I look forward to the chat-through

Okay, let’s go back to the start… I am actually on Ubuntu 14.04, but I would imagine things are pretty standard. How do you generally operate your commands? are you using the console provided from your DO droplets page?, no disrespect to DO, but I actually found that unbelievably slow and well… cr*p to be honest (LOL)… Have you considered using PuTTY? It’s so much easier and will likely save you a lot of hassle in the long run. You can also create your public/private keys using PuTTYgen. However, for now, let’s assume that you have a public/private key pairing. You would add the public key to your account settings/security page… actually, bear with me… I have a site I can use to throw up some basic instructions for you if you like… I can open up the comments section to so that you are able to kind of chat if you like? It’s going to be much easier for me to guide you through if I am able to provide you with images along the way… I’ve been writing tutorials for a while now and have plenty of edited screenshots to help you… Its entirely up to you, but I’ve been where you are and it was no fun at all, so I’m more than happy to help… Give me 5 minutes to take down a “coming soon” page and I’ll open it up for you.

LOL… I made that mistake once… took me all of 30-60 seconds to destroy the droplet and create a new one, however I do understand that it can be a little frustrating at times. Not sure how far along you are or exactly how n00b you are, but I do want you to understand that I’m not being rude here okay, but I have to ask… you have created your public and private keys and added your public key to your account settings/security right? …and then you created your droplet with your key embedded? If you are so new that you aren’t sure what I’m on about, just reply, I’m more than happy to help you through if you want the help.

If your root user has a password (you did not use an SSH key for authentication) you should still be able to log in as root via the console in the control panel. This is not dependent on the ssh service and will allow the root user to login so you can investigate and resolve the problem.