After Laravel Forge setup, "Permission denied (publickey)"

Yesterday I created a Digital Ocean account and connected with Laravel Forge. I generated a new droplet via Forge. After it’s created, I try to log in using keys. I keep getting an “Permission denied (publickey)” error. I tried deleting the contents of my known_hosts file. After attempting to connect I got the untrusted server message and opted in. The new key was written to my known_hosts. And then the same error appeared.

Any ideas or tests I can run to see what’s happening?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Rich: <br> <br>I hit this problem as well. Here’s the solution (assuming you’ve already correctly added your public key to the Forge UI)… <br> <br>In the welcome email it says your username is “forge”. So use this on the command line, and replace with your server’s IP: <br> <br>ssh forge@ <br> <br>Hope that helps.

For those whom tried using the pbcopy on the GitBash command and did not work try: $ clip < ~/.ssh/ It will basically copies your SSH Key to a clipboard, paste it to your Forge Dashboard. Once that is done, try to log in using ssh name@your-ip -i ~/.ssh/

***Can someone tell me how can I login to my database now? Should I use Digital Ocean at all anymore?

I have same problem . I need help .