Question

After turning my droplet off and then back on, my domain wont show my django app? the server connections times out/restarts/stops responding

Posted November 13, 2019 681 views
DigitalOceanDjangoUbuntu 18.04

I have had a django app deployed on a droplet with gunicorn and nginx setup. The app has been running beautifully for 3.5months. Today, I needed to take a snapshot. So I turned off the droplet(using ‘poweroff’) inside the console-access within the digitalocean site. I started the snapshot when it was 30-40% complete digitalocean gave a pop-up saying something went wrong with snapshot. I thought it failed so i refreashed the page to see if the snapshot would still be there with is progess bar and it was. it then completed its process and a snapshot was created. I then turned back on the droplet using the websites UI and then tried to go to my sites domain; with no successful response.

I have tried everything trying to get it to work!

I have ran the lines:

  • 'systemctl daemon-reload’
  • 'systemctl restart gunicorn’
  • 'systemctl restart nginx’

No Luck

  • Checked all Nginx and Gunicorn files
  • Checked the status of nginx conf ('nginx -t’)
  • Checked the status of gunicorn and gunicorn.socket
  • went through the Nginx, postgres, gunicorn setup with django in ubuntu 18.04 tutorial !4times!
  • checked django settings file.
  • checked DNS

Everything is right and working but I cant access my site from its domain or its IP.

I then used whois to make sure my domain was working; it was. I used whois to check the IP address to make sure it was working; it was. I checked the reverse of the server IP and got my domain in response. EVERYTHING APPEARS CORRECT. Yet, its not working.

Someone please help. quick. My site is essential for a business.

The domain is 'bluegrasspetcrematorium.com’ if anyone needs to see the response browsers give.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

When you turn off the droplet, you must enter from your DO account, and activate the firewall from there. Don’t do it from putty / ssh or it won’t work. Although your problem may not be this, but try this: sudo ufw disable / enable.
In my video tutorial I explain how to do it (English subtitles):

https://www.youtube.com/watch?v=mNw7EyXtT_k&t=679s

  • Hey, so it turns out that when I created the snap shot is messed up the network connection and like it cant be fixed so I put in a ticket just to try and retrieve certain files. but if anyone ever finds a solution to fixing a droplets network connection please share. like it cant ping or apt-get or anything requiring internet.

Submit an Answer