Question

After update to Ubuntu 14.10, login still reports "Welcome to Ubuntu 14.04.1..."

  • Posted on November 4, 2014
  • jonesAsked by jones

Updated from Ubuntu 14.04 to Ubuntu 14.10 x64 vmlinuz-3.16.0-23-generic by using Control Panel > Settings > Kernel. Followed procedure (save new kernel in control panel, power off on command line, then boot in control panel. Next command line log in (ssh) shows “Welcome to Ubuntu 14.04.1 LTS (GNU/Linux 3.16.0-23-generic x86_64)”. Kernel is correct, but Ubuntu version is not. No change after sudo apt-get update & sudo apt-get dist-upgrade & sudo apt-get autoremove.

Meanwhile, Control Panel > Settings > Kernel reports 14.10.

Should I ignore the command line report, or am I missing an upgrade step?

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It sounds like you’ve changed the kernel but not actually upgraded the rest of your system to 14.10. To check, look at the contents of the release file: cat /etc/os-release

In order to do a full upgrade, you need to run:

sudo apt-get update
sudo apt-get upgrade
sudo do-release-upgrade -d

Note the -d flag. It will check for the current “devel release.” While 14.10 has been officially released, the release upgrader isn’t yet suggesting it, so you’ll need to use the -d flag. Normally you should not need it.

Running do-release-upgrade -d should fix that.