Question

After upgrading to Ubuntu20 from Ubuntu18, mysql is not working.

I upgraded from Ubuntu 18 to Ubuntu 20. mySQL upgrade failed during the upgrade.

After the upgrade, I again tried to install mysql-server. I’m getting the below error:

Error while setting value 'STRICT_TRANS_TABLES,ERROR_FOR_DIVISION_BY_ZERO,NO_AUTO_CREATE_USER,NO_ENGINE_SUBSTITUTION' to 'sql_mode'.

Command used:

sudo apt install mysql-server

I used the above command after upgrade to Ubuntu20.

I even tried to edit the configuration, but that didn’t help.

[mysqld]
sql_mode="STRICT_TRANS_TABLES,NO_ENGINE_SUBSTITUTION"

Added the above two lines in /etc/mysql/mysql.cnf.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi there,

It looks like that the sql_mode value might already be specified in some of your configuration files already.

I could suggest using the grep command to search for any references of sql_mode and update them accordingly:

grep -ri  "sql_mode" /etc/mysql/*

The values are mostlikely specified in the `/etc/mysql/mysql.conf.d/mysqld.cnf file.

I was able to replicate the problem on Ubuntu 20.x with the sql_mode values from the error.

Regards, Bobby