akismet .htaccess order not allowed error

August 21, 2014 4.3k views

I’m a little bit desperate at all.
I can’t access to wordpress admin site via browser (it appears a entire white page, without any error message), so I check via FTP the apache2 log files.

The error log file is full of error lines like the following since days ago:

Tue Aug 19 17:27:45.701152 2014] [core:alert] [pid 19099] [client] /var/www/wp-content/plugins/akismet/.htaccess: order not allowed here, referer: http://theforeigner.es/el-yihadismo-como-cuento-de-nunca-acabar/ 

I have any problem since yesterday when I installed a new theme. Then, it appears a different error line in the log:

[Wed Aug 20 08:50:57.995767 2014] [core:alert] [pid 21000] [client] /var/www/wp-content/plugins/akismet/.htaccess: order not allowed here, referer: http://theforeigner.es/wp-admin/customize.php?theme=the-newswire

How can I solve this problem in order to restore my wordpress webpage? I tried to disable all plugins renaming the plugins folder, but the page is still appearing fully blank.

I tried also to rename the theme folder, but still no solution.
The only change I noted it is that when I try to go to wp-admin on the browser (myIP/wp-login.php) it redirects me to http://theforeigner.es/wp-login.php?redirect_to=http%3A%2F%2F95.85.26.157%2Fwp-admin%2Findex.php&reauth=1 but without any result.

Thanks in advance!

1 Answer

Could you post more information about your Apache configuration? Most likely, this is due to an AllowOverride None somewhere in your configuration. Try adding this:

<Directory "/var/www/wp-content/plugins/akismet/">
     AllowOverride All

That’s probably too permissive. You’ll want to limit it somewhat, but if this works then you know the root issue.

Have another answer? Share your knowledge.