All Directory in Joomla 2.5.14 unwritable.

  • Posted on September 2, 2013
  • thanhhx57Asked by thanhhx57

Hi all,

I just moved my site to store in DigitalOcean. I installed Virtualmin to manage VPS on Ubuntu 12.04 32bit. Everything goes well but can not write, clear the cache on site, … :( All Directory in Joomla 2.5.14 unwritable. I have checked throught FTP (FileZilla) and they all seem to be set to 755 and files for 644.

I do not know how to permission directories are writable. You know what helped me with. Thanks!

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

I don’t have any FTP server (and I don’t want to have) so I can only use the direct method.

But now when I tried to update Joomla from 3.2.3 to3.2.4 with Joomla Update and Installation method “Write files directly” I get ERROR: <br>Could not open /home/myuser/public_html/joomla root directory/LICENSE.txt for writing. When I do sudo chgrp -R www-data /home/myuser/public_html/joomla root directory/LICENSE.txt it obviously works for that file as well. But to make the whole update work I guess I need to run sudo chgrp -R www-data /home/myuser/public_html/joomla root directory/ <br> <br>Is that a security risk to do sudo chgrp -R www-data /home/myuser/public_html/joomla root directory/ ?

Thanks Kamal, sudo chgrp -R www-data /home/myuser/public_html/directory worked like a charm! <br> <br>Before I found this page I tried chown -R myuser:myusersgroup /home/myuser/public_html/directory* but it didn’t work at all.