Question

All visitors need admin credentials to access website

Hi folks,

New person here.

I recently directed a domain (domain.com) to my website, which I host using DigitalOcean running Ubuntu WordPress on 14.04. While I was building this site, I would access it by going to the IP address (let’s call it 123.456.78.90/), and then be prompted with a log-in (I would enter admin and then a password and get in fine).

Now when anyone visits domain.com, all they say is that request for the log-in credentials of the server admin. I need to make that go away so people can access my site without knowing this info. How do I do this?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This comment has been deleted

You can fully disable this prompt fairly easily. It is defined in a DirectoryMatch directive in /etc/apache2/apache2.conf (just look for the one with AuthType:Basic in it and delete the whole <DirectoryMatch> block). Once it has been removed, restart apache with:

service apache2 restart

You should no longer see the prompt.