Question

Amazon SES not finding TXT DKIM in DNS section ?

Title says it all; trying to verify my domain using the DNS settings in DigitalOcean and twice now, Amazon has failed to verify it

I have added the TXT and 3 CNAME values to the DNS record; I’ve tried with the _ in the TXT entry and without (as i’ve read elsewhere) and it continues to fail verification.

Any ideas?


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

You have 3 CNAMEs containing “_domainkey” and 2 TXT records containing “amazonses”. Edit <strong>all</strong> of them and add a dot at the end of each so that e.g.: <br> <br><code>_amazonses.domain.co</code> becomes <code>_amazonses.domain.co.</code>

Hi - just to add to this thread. For TXT values Do add a period at the end of the key (post 1) Enclose Value in double quotes Add new TXT _amazonses.domain.co. “LOng+Key”

Strangely enough (for me) the RAW Zone file (at the bottom) reads _amazonses.domain.co. 1800 IN TXT “LOng+Key”

and the entry reads _amazonses “LOng+Key”

HTH

You can test your DigitalOcean DNS settings from the linux command line by doing this:

For TXT entries: host -t txt _amazonses.domain.ext ns1.digitalocean.com

For CNAME entries: host -t cname secrethash._domainkey.domain.ext ns1.digitalocean.com

Hope this helps some people.