Amazon SES not finding TXT DKIM in DNS section ?

Posted August 12, 2013 21.2k views
Title says it all; trying to verify my domain using the DNS settings in DigitalOcean and twice now, Amazon has failed to verify it I have added the TXT and 3 CNAME values to the DNS record; I've tried with the _ in the TXT entry and without (as i've read elsewhere) and it continues to fail verification. Any ideas?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
13 answers
You have 3 CNAMEs containing "_domainkey" and 2 TXT records containing "amazonses". Edit all of them and add a dot at the end of each so that e.g.: becomes

Hi - just to add to this thread.
For TXT values
Do add a period at the end of the key (post 1)
Enclose Value in double quotes
Add new TXT

Strangely enough (for me) the RAW Zone file (at the bottom) reads 1800 IN TXT “LOng+Key”

and the entry reads
_amazonses “LOng+Key”


that worked and its already verified. thank you, Kamal CNAME
Do I need to add dots to both name and hostname?
Kamal, thank you for explaining everything to me! Verified!
Hey guys.. i had mine verified by Amazon is telling that some of the stuff is failing.

here's the screenshot

Any thoughts on this?
@taewoo: Can you post a screenshot of the records in DigitalOcean's DNS Manager?
Hey I got the same issue as @taewoo Were you able to some that issue?
Previous 1 2 Next