Question

Any SSH related command ends with "Permission denied (publickey)"

Posted October 3, 2017 1.9k views
Linux BasicsLinux CommandsUbuntu 16.04

I created this Droplet a few months ago. After some time i tried to connect to it again. I got everytime I tried

$ ssh user@server
Permission denied (publickey)

So I just tried to follow the steps again in this tutorial:

https://www.digitalocean.com/community/tutorials/how-to-set-up-ssh-keys–2

But anything that connects to the server with SSH (ssh-copy-id) ends abruptly with “Permission denied (publickey)”

The public key I created last was added in Settings > Security > SSH Keys

Any ideas?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
Submit an Answer
2 answers

Hello,

You would need to redeploy the SSH key to your droplet, only adding the SSH key to the Settings > Security > SSH Keys does not actually deploy the key to the existing droplet itself unless you specify so during the droplet creation.

You can follow the steps on how to regain access to your server here:

https://www.digitalocean.com/docs/droplets/resources/console/

Hope that this helps!
Regards,
Bobby

Hello there,

You can check our article on How to Upload an SSH Public Key to an Existing Droplet

https://www.digitalocean.com/docs/droplets/how-to/add-ssh-keys/to-existing-droplet/

You can access the droplet from the DigitalOcean console and then temporary enable the PasswordAuthentication on your droplet and access the droplet with a password to upload the ssh-key.

If you haven’t created new pair of keys you’ll need to do that first.

You can enable PasswordAuthentication for your Droplet by modifying your /etc/ssh/sshd_config file. Once set to Yes restart the SSH service and connect via an SSH client for a more stable connection. You can then modify your ~/.ssh/authorized_keys file to add the appropriate public key.

This change can be made from the DigitalOcean’s console. If you’re having issues accessing the console you can then reach to our amazing support team that can help you further with this.

To enable the PasswordAuthentication follow these steps:

  1. Login to the console on the DigitalOcean website.
  2. Type sudo nano /etc/ssh/sshd_config
  3. Change PasswordAuthentication from “no” to “yes” and save the file
  4. Open a terminal on your computer and type ssh username@[hostname or IP address] or if on a Windows box use PuTTY for password login making sure authentication parameters aren’t pointing to a private key
  5. Login with a password
  6. Type sudo nano ~/.ssh/authorized_keys
  7. Paste public key text here and save the file
  8. Type sudo nano /etc/ssh/sshd_config
  9. Change PasswordAuthentication from “yes” to “no” and save the file
  10. Log out and attempt to log back in (if using PuTTY make sure you set up auth parameters to point to your private key)

You can then upload the key using this command:

ssh-copy-id -i ~/.ssh/mykey user@droplet

Hope that this helps!
Regards,
Alex