Question

Apache broke after upgrading php and apache

Posted September 8, 2014 3.1k views

Hello,
I tried to upgrade my php version and somehow the apache version also upgraded. After this upgrade I got a lot of errors obviously and I managed to solve lots of them except this one

apache2: Syntax error on line 210 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/authmysql.load: Cannot load /usr/lib/apache2/modules/modauthmysql.so into server: /usr/lib/apache2/modules/modauth_mysql.so: cannot open shared object file: No such file or directory

The module doesn’t exist as I checked. How can I solve this? I tried to google all the way but I can’t seem to find a correct answer.

Any help would be awesome :) Thanks in advance guys!

edit I think this problem occurs because of iredmail that depends on that module. Could this be possible?

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

You could just disable the mod, restart apache and see what works and what doesn’t.

Try something like:

a2dismod auth_mysql

You’re probably right in saying iredmail needs that mod enabled. Have you tried just installing the mod?

Try this:

sudo apt-get install libapache2-mod-auth-mysql

Restart apache

service apache2 restart
Submit an Answer