Question

Apache causing massive load spike after reboot

My server is running Ubuntu 18.04.5 LTS, with LAMP stack (PHP 7.4), and apache version 2.4.29 using Prefork MPM. My server has 16 CPUs and 29GB of RAM. This server hosts 258 websites.

Whenever I reboot my server, I notice (using top command) that apache is creating a crazy amount of processes. This is completely overloading the server. This ONLY happens when I reboot the server, or I manually stop apache (service apache2 stop) and then start apache (service apache2 start).

Normally this is the output of top (during normal hours):

https://drive.google.com/file/d/163-N2dq_ARKAICQEwnWA0SaLPLxtlOls/view?usp=sharing

After rebooting or stopping and starting apache manually, the load average climbs to over 126.4! It slowly (over about 10-15 minutes) goes back to normal. For the first 5 minutes after rebooting or stopping and starting apache, the load just steadily climbs until it gets to about 126-130.

Here is my MPM configuration (/etc/apache2/mods-enabled/mpm_prefork.conf):

<IfModule mpm_prefork_module> StartServers 5 MinSpareServers 5 MaxSpareServers 10 MaxRequestWorkers 150 MaxConnectionsPerChild 0 </IfModule>

Also KeepAlive is ON, MaxKeepAliveRequests is 100, and KeepAliveTimeout is 2.

What is very strange, is I made an exact copy of the server, and placed a handful of sites (6 websites) on the copy, and when I reboot, or start and stop apache on this copy server, this behavior does not happen. This is an EXACT copy of the server mentioned above, it is just only hosting 6 websites (WAY less traffic) instead of 258.

Could this problem be caused by too many client connections waiting on apache to respond during reboot, and when apache server finally comes back up it floods apache with connections?

Would increasing the values in my MPM configuration possibly help this? I’ve checked logs, and I never go over MaxRequestWorkers.

It has been suggested that I move from mpm_prefork to php-fpm and mod_event but for certain reasons this is not practical for me. I need to keep mpm_prefork.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hello, @alhxcex

As you mentioned the issue is most probably caused by the fact that too many connections are waiting for the Apache server to respond. Also, the fact that you’re using mpm_prefork which does not support multi-threading is causing Apache to create multiple requests which overload the server in case of a reboot or restart of the Apache service.

If you switch to mpm_worker_module or mpm_event_module you will experience a significant difference in the performance.

Event is based on the worker MPM, which implements a hybrid multi-process multi-threaded server. A single control process (the parent) is responsible for launching child processes. Each child process creates a fixed number of server threads as specified in the ThreadsPerChild directive, as well as a listener thread that listens for connections and passes them to a worker thread for processing when they arrive.

You can check the information here:

https://httpd.apache.org/docs/current/mod/worker.html

https://httpd.apache.org/docs/2.4/mod/event.html

You can also play adjust the Apache workers configuration and try to tweak them and also change the php-fpm pool settings in order to optimize the settings based on the websites traffic.

In my experience, with mpm_prefork_module the performance will always suffer due to the lack of multi-process multi-threading.

Hope that this helps! Regards, Alex