Scale up as you grow — whether you're running one virtual machine or ten thousand.

From GPU-powered inference and Kubernetes to managed databases and storage, get everything you need to build, scale, and deploy intelligent applications.

By pmartelletti
Hi Everyone,
I’ve recently update PHP version in my server, and after that my apache configuration seems to be broken, and I’m not able to fix it.
If it helps, when updating, the ubuntu installer told me that the package had new configuration files that override the old ones, but told me that the default action was NOT to override them, and therefore, that’s what I did. It seems now that the new version of apache is looking for that configuration files, and as I kept the old ones, it’s very broke… :S
Do have any ideas of what should I do to fix it, without reinstalling the server and not loosing any virtualhost?
The error I get is:
apache2: Syntax error on line 211 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/fcgid.load: Cannot load /usr/lib/apache2/modules/mod_fcgid.so into server: /usr/lib/apache2/modules/mod_fcgid.so: cannot open shared object file: No such file or directory
But basically, some other errors were founded until i fix them, but was not able to fix this. It has to do with PHP upgrade from 5.3 to 5.5.
Thanks in advance!