Question

Apache default vhost overrides the custom ones

  • Posted on November 11, 2014
  • KowAsked by Kow

I’ve just created a LAMP droplet from the applications.

My default vhost overrides my new one, so /var/www/html loads for me for a new domain.

http://pastebin.com/wnYtXex5

Things I tired:

  • The symlink is enabled in the /sites-enabled directory
  • Apache is restarted with no error message
  • Replaced *.80 with the IP, but didn’t help
  • Added ServerName localhost to the apache2.config
Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

There’s a typo in your virtual host config: 188.226.156.206 should be 188.226.145.206 instead. Though you should probably keep it set to *:80. Do you have any other virtual hosts enabled? Make sure that the symlink in /etc/apache2/sites-enabled ends in .conf.

Yes, then it listed my /var/www directory