[centos@ip-172-31-19-60 ~]$ sudo systemctl status httpd.service -l
● httpd.service - The Apache HTTP Server
Loaded: loaded (/usr/lib/systemd/system/httpd.service; disabled; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2020-04-13 06:51:48 UTC; 21min ago
Docs: man:httpd(8)
man:apachectl(8)
Process: 1355 ExecStop=/bin/kill -WINCH ${MAINPID} (code=exited, status=1/FAILURE)
Process: 1354 ExecStart=/usr/sbin/httpd $OPTIONS -DFOREGROUND (code=exited, status=1/FAILUR E)
Main PID: 1354 (code=exited, status=1/FAILURE)

Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal httpd[1354]: (13)Permission denied : AH00072: make_sock: could not bind to address 0.0.0.0:10
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal httpd[1354]: no listening sockets available, shutting down
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal httpd[1354]: AH00015: Unable to op en logs
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: httpd.service: main pr ocess exited, code=exited, status=1/FAILURE
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal kill[1355]: kill: cannot find proc ess “”
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: httpd.service: control process exited, code=exited status=1
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: Failed to start The Ap ache HTTP Server.
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: Unit httpd.service ent ered failed state.
Apr 13 06:51:48 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: httpd.service failed.
Apr 13 06:59:34 ip-172-31-19-60.us-east-2.compute.internal systemd[1]: Unit httpd.service can not be reloaded because it is inactive.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

×
1 answer

Hi @prathiabhishek,

Looking at the provided logs, I can see a couple of issues. Firstly, Apache is trying to start and listen on port 10. Have you changed the default configuration about port 80 to port 10? If you have, make sure the port is not used by another service. If you intend to use port 10, then execute the following command

netstat -tulpne | grep 10

See if anything is listening on it.

Another issue might be the lack of space/inodes on your Droplet.

You can check it by executing the following commands

df -h
df -i

If you have any of the partitions full, please make sure to free some space.

Lastly, when you try to restart apache and it fails, please do check

journalctl -xe

It should provide you with the full error behind the failing.

Regards,
KDSys

  • Hello @KDSys,

    I have added multiple port numbers alongside the port 80 for the purpose of virtual hosting through port numbers. I haven’t deleted the port 80.

    Thank you.

    • For this aproach to work, you’ll need to have multiple IP addresses.

      It’s a lot easier if you use the standard way. Ports 80 and 443 are used to accept http/https requests and have different Virtualhost files for separate domains.

      https://www.digitalocean.com/community/tutorials/how-to-set-up-apache-virtual-hosts-on-ubuntu-18-04

      There is a reason why it’s the standard way, it’s the most efficient and proven.

      Regards,
      KDSys

      by Lisa Tagliaferri
      This tutorial will guide you through setting up multiple domains and websites using Apache virtual hosts on an Ubuntu 18.04 server. During this process, you’ll learn how to serve different content to different visitors depending on which domains they are requesting.
      • Hello @KDSys

        I was practicing the way of hosting different websites with multiple port numbers in AWS Instance. So I will be getting only 1 IP address.

        And my Apache Httpd started working once i disabled the SELINUX using the following code

        sudo nano /etc/selinux/config

        And restarted the httpd, It’s Active and running.

        I thank you for taking your time and helping me.

        Have a good one,

        Regards,
        Abhishek.

Submit an Answer