Question

Apache2 directory listing issue

Hi,

I am trying to make a media source for XBMC, I have everything working so far and I can see all the files listed, but XBMC will not list the links and files. I know this is because of the formatting of the directory (Index of) page.

Mine loads as below:

http://magic.littlesmartbox.com

A working example would be:

http://fusion.tvaddons.ag

How do I get my directory to list the same as the working example above? Am I missing something?

Many thanks

Tyler

Show comments

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

I have a droplet running Apache2 on Ubuntu 14.04 and got here because this is the first result on the searches.

I had a different problem, I did not want my folders indexed, I wanted to prevent directory listing, and .htaccess was not working, so I went to:

/etc/apache2/sites-available

and edited my 000-default.conf file to the following:

<VirtualHost *:80>

	ServerAdmin webmaster@localhost
	DocumentRoot /var/www/mysite


	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

	<Directory /var/www/mysite>
  		Options -Indexes
	</Directory>

</VirtualHost>

Fixed it, in the end I was using XBMC wrong to find the source, but you can turn off the fancy indexing sorting by using the below in a .htaccess file in the directory you want:

Options +Indexes IndexOptions IgnoreClient

:)