App Platform Does Not Recognize the Changes Made on Github Eventhough They Are Visible on

Hi everyone,

I am running a software built on DO App Platform. I have two private github repos that I am installing on the app platform manually. The problem is, app platform does not recognize the changes made on my github packages. When I make a change in my local and update the version of the package, then push it to GitHub, I can see the new files on But when I try to pip install or pip upgrade the packages on DO App Platform, it does not pull the new files. It updates the version (for example increases from 0.2.4 to 0.2.5) but the new files are not there. This happens either I made changes in the existing files content (whether it is .py file or .xlsx) or even if I add new files that weren’t there before. I tried installing it with --no-cache-dir as well but still the same result. The only solution I found is deleting the private repo entirely, then forcing a redeploy then re-installing it but this is not ideal.

I want to simply update the package as this is the entire point of having a github package, being able to easily implement updates. It is really strange because I can see the changes I made on, but app platform does not work properly and does something completely different than what is available on It only updates the version of the package and doesn’t recognize the changes made.

Does anyone have any idea how to solve this?

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Bobby Iliev
Site Moderator
Site Moderator badge
October 3, 2023

Hi there,

Have you tried forcing a redeployment? This sometimes can be a useful when hitting unusual problems that the one that you’ve described. By triggering a redeployment, you’re essentially asking the platform to reevaluate your code, dependencies, and other configurations, and this can often clear up certain transient issues.

Here’s how you can force redeploy on DigitalOcean’s App Platform:

  1. Navigate to your App’s dashboard in the DigitalOcean Control Panel.
  2. Click on the “Settings” tab.
  3. Under the “General” section, you’ll find a “Deploy” button. Clicking this will redeploy the current deployment, which can be useful if you believe there might have been an intermittent issue with the platform or some other transient problem.
  4. After the redeployment, check to see if your changes are reflected.

Also, just to be on the safe side, I could suggest double-checking that you are deploying from the correct branch.

Let me know how it goes!



Try DigitalOcean for free

Click below to sign up and get $200 of credit to try our products over 60 days!

Sign up

Get our biweekly newsletter

Sign up for Infrastructure as a Newsletter.

Hollie's Hub for Good

Working on improving health and education, reducing inequality, and spurring economic growth? We'd like to help.

Become a contributor

Get paid to write technical tutorials and select a tech-focused charity to receive a matching donation.

Welcome to the developer cloud

DigitalOcean makes it simple to launch in the cloud and scale up as you grow — whether you're running one virtual machine or ten thousand.

Learn more
DigitalOcean Cloud Control Panel