Apple is blocking DigitalOcean IPs, thus my Droplet, How to bypass that?

October 12, 2019 326 views
Networking

I’m trying to use fastlane on my droplet, but unfortunately it did not work because Apple is blocking requests from Digital Ocean.

Someone else had the same issue: https://github.com/fastlane/fastlane/issues/14602 and he fixed it by switching to aws.

I don’t want to switch to aws.

I tried installing a VPN on my droplet to change my IP but this caused me to loose SSH connection (since IP changed) and my hosted nginx server stopped working as well.

How can I fix this?

1 Answer

Hello,

I believe that this was asked before in the community, but the user was experiencing intermittent issues when doing API calls to iTunes using fastlane

If it comes to Apple blocking your droplet’s connections or the IP address itself, I believe you can try to reach to their support team and ask them if it’s possible to whitelist it (not sure if this is possible).

Other than that perhaps you can try with ssh tunelling and move to another server and try to connect from there.

Let me know how it goes.

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!