kwoxer
By:
kwoxer

apt-get 404 Not found errors anywhere

October 16, 2015 11.4k views
Linux Commands DigitalOcean

I never had a 404 issue like that. I did not change anything. I mentioned the issue when I tried to install something. So I've tried a simple update, which also gives a huge number of 404's. I have no idea how to fix. Must be something on DO side?

sudo apt-get update
Ign http://security.ubuntu.com utopic-security InRelease
Ign http://mirrors.digitalocean.com utopic InRelease
Ign http://security.ubuntu.com utopic-security Release.gpg
Ign http://mirrors.digitalocean.com utopic-updates InRelease
Ign http://security.ubuntu.com utopic-security Release
Ign http://mirrors.digitalocean.com utopic Release.gpg
Ign http://security.ubuntu.com utopic-security/main Sources/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates Release.gpg
Ign http://security.ubuntu.com utopic-security/universe Sources/DiffIndex
Ign http://mirrors.digitalocean.com utopic Release
Ign http://security.ubuntu.com utopic-security/main amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates Release
Ign http://security.ubuntu.com utopic-security/universe amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/main Sources/DiffIndex
Ign http://security.ubuntu.com utopic-security/main i386 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/universe Sources/DiffIndex
Ign http://security.ubuntu.com utopic-security/universe i386 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/main amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/universe amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/main i386 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic/universe i386 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/main Sources/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/universe Sources/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/main amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/universe amd64 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/main i386 Packages/DiffIndex
Ign http://mirrors.digitalocean.com utopic-updates/universe i386 Packages/DiffIndex
Ign http://security.ubuntu.com utopic-security/main Translation-en_US
Ign http://security.ubuntu.com utopic-security/main Translation-en
Ign http://security.ubuntu.com utopic-security/universe Translation-en_US
Ign http://security.ubuntu.com utopic-security/universe Translation-en
Err http://security.ubuntu.com utopic-security/main Sources
  404  Not Found [IP: 91.189.91.23 80]
Err http://security.ubuntu.com utopic-security/universe Sources
  404  Not Found [IP: 91.189.91.23 80]
Err http://security.ubuntu.com utopic-security/main amd64 Packages
  404  Not Found [IP: 91.189.91.23 80]
Err http://security.ubuntu.com utopic-security/universe amd64 Packages
  404  Not Found [IP: 91.189.91.23 80]
Err http://security.ubuntu.com utopic-security/main i386 Packages
  404  Not Found [IP: 91.189.91.23 80]
Err http://security.ubuntu.com utopic-security/universe i386 Packages
  404  Not Found [IP: 91.189.91.23 80]
Ign http://mirrors.digitalocean.com utopic/main Translation-en_US
Ign http://mirrors.digitalocean.com utopic/main Translation-en
Ign http://mirrors.digitalocean.com utopic/universe Translation-en_US
Ign http://mirrors.digitalocean.com utopic/universe Translation-en
Ign http://mirrors.digitalocean.com utopic-updates/main Translation-en_US
Ign http://mirrors.digitalocean.com utopic-updates/main Translation-en
Ign http://mirrors.digitalocean.com utopic-updates/universe Translation-en_US
Ign http://mirrors.digitalocean.com utopic-updates/universe Translation-en
Err http://mirrors.digitalocean.com utopic/main Sources
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic/universe Sources
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic/main amd64 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic/universe amd64 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic/main i386 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic/universe i386 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/main Sources
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/universe Sources
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/main amd64 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/universe amd64 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/main i386 Packages
  404  Not Found [IP: 95.85.0.50 80]
Err http://mirrors.digitalocean.com utopic-updates/universe i386 Packages
  404  Not Found [IP: 95.85.0.50 80]
W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/main/source/Sources  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/universe/source/Sources  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/main/binary-amd64/Packages  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/universe/binary-amd64/Packages  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/main/source/Sources  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/main/binary-i386/Packages  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/universe/source/Sources  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://security.ubuntu.com/ubuntu/dists/utopic-security/universe/binary-i386/Packages  404  Not Found [IP: 91.189.91.23 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/main/binary-amd64/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/universe/binary-amd64/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/main/binary-i386/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic/universe/binary-i386/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/main/source/Sources  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/universe/source/Sources  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/main/binary-amd64/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/universe/binary-amd64/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/main/binary-i386/Packages  404  Not Found [IP: 95.85.0.50 80]

W: Failed to fetch http://mirrors.digitalocean.com/ubuntu/dists/utopic-updates/universe/binary-i386/Packages  404  Not Found [IP: 95.85.0.50 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.
4 Answers

Ubuntu 14.10 (Utopic Unicorn) reached "End of Life" on July 23, 2015 and is no longer supported. Ubuntu has recently remove it from their official mirrors. If you still require the Apt repositories for it, you'll need to edit your /etc/apt/source.list to point to:

http://old-releases.ubuntu.com/

We've also set up a mirror for it at:

http://mirrors.digitalocean.com/ubuntu-old

Though you are strongly encouraged to upgrade to a more recent release. Security updates are no longer provided for any packages in 14.10. We are providing that repository as a convenience and temporary work around for those who haven't upgraded to a supported release yet.

Upgrading to 15.04 helped out. Now it's working again. Thanks.

thanks for article , after updating source.list it worked

@asb : Thanks, it really worked for me by replacing Utopic (archive.ubuntu.com) source urls with http://old-releases.ubuntu.com/ .

Have another answer? Share your knowledge.