apt-get install several problems

Good Evening, I am trying to install postgres pack, but now i am in front of a problem in my droplet.

every time i shot “apt-get install postgresql-9.3” i get following error:

Reading package lists… Done Building dependency tree Reading state information… Done You might want to run ‘apt-get -f install’ to correct these: The following packages have unmet dependencies: openjdk-7-jre : Depends: libpulse0 (>= 1:0.99.1) but it is not going to be installed postgresql-9.3 : Depends: libpq5 (>= 9.1~) but it is not going to be installed Depends: postgresql-client-9.3 but it is not going to be installed Depends: postgresql-common (>= 142~) but it is not going to be installed E: Unmet dependencies. Try ‘apt-get -f install’ with no packages (or specify a solution).

i already did :

apt-get -f install libpulse0 apt-get -f install apt-get -f update apt-get -f upgrade

But i got no success.

Do you have idea what it could be caused by?

Att, Marcello Ribeiro

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

it shouldn’t be that hard to make through, do this one by one accordingly: <br> <br>apt-get -f install <br> <br>apt-get install libpulse0 <br> <br>apt-get install libpq5 <br> <br>apt-get install postgresql-client-9.3 <br> <br>apt-get install postgresql-common <br> <br>and last run your desired package: <br> <br>apt-get install postgresql-9.3 <br> <br>do that and see if things work for you!!