Question

Archive_Zip problem Roundcube in Virtualmin.

  • Posted on March 24, 2020
  • PHP
  • MurtoAsked by Murto

Roundcube does not work: STATUS: Internal error occurred. Refer to server log for more information…

Error in logs:

PHP Error: php_zip extension is required for the zipdownload

And i use Virtualmin. I tried install from the PHP Pear Modules in Virtualmin but i got an error.

I installed with ssh with this method: pear install archive_zip-beta

I can see install module name (Archive_Zip) on Virtualmin. But roundcube gives the same error.

Please help.


Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

It appears to be installed, but the roundcube says it is still not installed…

https://imgur.com/tBRWGTy

Hi there @incegozmuratcan,

What you could do is install the PHP ZIP module with the following command:

  1. php-zip

Then you should also restart Apache or Nginx depending on which one you are using, and it should be ok after that.

Let me know how it goes. Regards, Bobby