Asterisk with kernel-devel

Posted May 28, 2013 18.1k views
Hi, I am trying to install Asterisk 1.8.x on vps, but I recognize the header my kernel on centos 6.4 : kernel-2.6.32-358.6.2.el6.x86_64 kernel-devel-2.6.32-358.6.2.el6.x86_64 error: [root@shark dahdi-linux-2.6.2]# make make -C drivers/dahdi/firmware firmware-loaders make[1]: Entering directory `/usr/src/dahdi-linux-2.6.2/drivers/dahdi/firmware' make[1]: Leaving directory `/usr/src/dahdi-linux-2.6.2/drivers/dahdi/firmware' You do not appear to have the sources for the 2.6.32-358.6.2.el6.x86_64 kernel installed. make: *** [modules] Error 1 I have the same kernel in the droplet kernel-2.6.32-358.6.2.el6.x86_64

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
12 answers
Try installing the kernel-devel package:

yum install kernel-devel
I have already installed

122 packages excluded due to repository priority protections
Setting up Install Process
Package kernel-devel-2.6.32-358.6.2.el6.x86_64 already installed and latest version
Nothing to do
@netsoluciones Try running ("yum update kernel") and ("yum install kernel-PAE-devel")
Not found

yum list | grep -i kernel
dracut-kernel.noarch 004-303.el6 @base
kernel.x86_64 2.6.32-358.6.2.el6 @updates
kernel-devel.x86_64 2.6.32-358.6.2.el6 @updates
kernel-firmware.noarch 2.6.32-358.6.2.el6 @updates
kernel-headers.x86_64 2.6.32-358.6.2.el6 @updates
abrt-addon-kerneloops.x86_64 2.0.8-15.el6.centos base
erlang-kernel.x86_64 R14B-04.2.el6 epel
fortune-kernelcookies.x86_64 1.0-37.2.el6.rf rpmforge
fortune-kernelnewbies.x86_64 1.0-37.2.el6.rf rpmforge
kernel-debug.x86_64 2.6.32-358.6.2.el6 updates
kernel-debug-devel.x86_64 2.6.32-358.6.2.el6 updates
kernel-doc.noarch 2.6.32-358.6.2.el6 updates
kerneloops.x86_64 0.11-1.el6.rf rpmforge
libreport-plugin-kerneloops.x86_64 2.0.9-15.el6.centos base
php-symfony2-HttpKernel.noarch 2.2.1-1.el6 epel

yum install kernel-devel-$(uname -r)
For the benefit of Googlers that may land on this thread in the future, check out: How To Install FreePBX on CentOS 6.4.
After much pain with this, I finally worked out a solution and now have a working PBX on DO.

Simply take the kernel version from the error (You do not appear to have the sources for the 2.6.32-358.6.2.el6.x86_64 kernel installed.) and find an rpm for kernel-devel that matches this version (e.g. google kernel-devel 2.6.32-358.6.2.el6.x86_64). You'll probably see one on or something.

Once you have the url for it, just run an rpm -ivh (where the url matches the kernel sources you require).

Then run make again, and you should be golden!



I had a solution setting a direct access to the new kernel-headers instaled in my VPS.

My kernel instaled after using yum update was 2.6.32-431.23.3.el6.x8664 (but I’m using the 2.6.32-358.6.2.el6.x8664, not match)

Goto the folder /lib/modules/2.6.32-358.6.2.el6.x86_64 (my actual kernel-modules used)

cd /lib/modules/2.6.32-358.6.2.el6.x86_64

Remove the direct access “build” using de command:

rm -f build

Set the new direct access using the command (in my case):

ln -s /usr/src/kernels/2.6.32-431.23.3.el6.x86_64

That all folks! You can compile and install DAHDI correctly.

Hope this helps.

I have a similar problem:

[root@sip 2.6.32-504.1.3.el6.x8664]# cd /usr/src/dahdi-linux-complete*
[root@sip dahdi-linux-complete-]# make && make install && make config
make -C linux all
make[1]: Entering directory /usr/src/dahdi-linux-complete- ux'
make -C drivers/dahdi/firmware firmware-loaders
make[2]: Entering directory
/usr/src/dahdi-linux-complete- ux/drivers/dahdi/firmware’
make[2]: Leaving directory `/usr/src/dahdi-linux-complete- x/drivers/dahdi/firmware’
You do not appear to have the sources for the 2.6.32-431.
64 kern el installed.
make[1]: *** [modules] Error 1
make[1]: Leaving directory `/usr/src/dahdi-linux-complete- x’

I have tried the solutions above and many more online.

Can anyone help?


  • @thebeanieman, your problem is probably that you did a yum update and the kernel did not update completely (you got a template error happend to me also).
    Because you did not set the right kernel in the digital ocean’s console panel> settings> kernel.
    Just look at the kernel it tries to update (by yum) en set that one in the console.
    You can check if it worked by uname -r
    This should reflect the new kernel.

Previous 1 2 Next