Question

authentication not enabled | postfix

When sending a test mail from my wordpress newsletter plugin i get the error AUTH command failed: 503 5.5.1 Error: authentication not enabled My system has Ubuntu and postfix

When i try the command it outputs :

/etc/postfix$ postconf | grep smtpd_sasl_auth_enable
smtpd_sasl_auth_enable = no

But when looking at my master.cf i see

# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       -       -       -       smtpd
#smtp      inet  n       -       -       -       1       postscreen
#smtpd     pass  -       -       -       -       -       smtpd
#dnsblog   unix  -       -       -       -       0       dnsblog
#tlsproxy  unix  -       -       -       -       0       tlsproxy
submission inet n       -       -       -       -       smtpd
  -o syslog_name=postfix/submission
  -o smtpd_tls_wrappermode=no
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
#  -o smtpd_reject_unlisted_recipient=no
#  -o smtpd_client_restrictions=$mua_client_restrictions
#  -o smtpd_helo_restrictions=$mua_helo_restrictions
#  -o smtpd_sender_restrictions=$mua_sender_restrictions
#  -o smtpd_recipient_restrictions=
#  -o smtpd_relay_restrictions=permit_sasl_authenticated,reject
#  -o milter_macro_daemon_name=ORIGINATING
#smtps     inet  n       -       -       -       -       smtpd
#  -o syslog_name=postfix/smtps
#  -o smtpd_tls_wrappermode=yes
   -o smtpd_sasl_auth_enable=yes
#  -o smtpd_reject_unlisted_recipient=no
#  -o smtpd_client_restrictions=$mua_client_restrictions
#  -o smtpd_helo_restrictions=$mua_helo_restrictions

Already tried a reload Also in the var/log/mail.log i am seeing:

Feb 13 07:06:45 cheapmailing postfix/smtpd[13646]: warning: dict_nis_init: NIS domain name not set - NIS lookups disabled
Feb 13 07:06:45 cheapmailing postfix/smtpd[13646]: connect from unknown[my.dropplets.ip.address]
Feb 13 07:06:45 cheapmailing postfix/smtpd[13646]: disconnect from unknown[my.dropplets.ip.address]

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

This didn’t work for me.

I am having the worst trouble trying to setup postfix/dovecot behind a Comcast residential gateway (SMTP port 25 block).

503 5.5.1 Error: authentication not enabled

Here’s some of the “/etc/postfix/master.cf”:

==========================================================================

smtp inet n - - - - smtpd #smtp inet n - - - 1 postscreen #smtpd pass - - - - - smtpd #dnsblog unix - - - - 0 dnsblog #tlsproxy unix - - - - 0 tlsproxy #submission inet n - - - - smtpd -o syslog_name=postfix/submission -o smtpd_tls_security_level=encrypt -o smtpd_sasl_auth_enable=yes

-o smtpd_reject_unlisted_recipient=no

-o smtpd_client_restrictions=$mua_client_restrictions

-o smtpd_helo_restrictions=$mua_helo_restrictions

-o smtpd_sender_restrictions=$mua_sender_restrictions

-o smtpd_recipient_restrictions=

-o smtpd_relay_restrictions=permit_sasl_authenticated,reject

-o milter_macro_daemon_name=ORIGINATING

587 inet n - - - - smtpd -o syslog_name=postfix/smtps

-o smtpd_tls_wrappermode=yes

-o smtpd_sasl_auth_enable=yes

-o smtpd_reject_unlisted_recipient=no

-o smtpd_client_restrictions=$mua_client_restrictions

-o smtpd_helo_restrictions=$mua_helo_restrictions

-o smtpd_sender_restrictions=$mua_sender_restrictions

---- Here’s some of the “/etc/postfix/main.cf” modifications made following this article (https://samhobbs.co.uk/2013/12/raspberry-pi-email-server-part-2-dovecot):

mynetworks = 127.0.0.0/8 [::ffff:127.0.0.0]/104 [::1]/128 mailbox_size_limit = 0 recipient_delimiter = + inet_interfaces = all inet_protocols = ipv4

home_mailbox = Maildir/ mailbox_command =

smtpd_recipient_restrictions = permit_sasl_authenticated, permit_mynetworks, reject_unauth_destination

smtpd_helo_required = yes smtpd_helo_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_invalid_helo_hostname, reject_non_fqdn_helo_hostname, reject_unknown_helo_hostname check_helo_access hash:/etc/postfix/helo_access

smtpd_sasl_type = dovecot smtpd_sasl_path = private/auth smtpd_sasl_auth_enable = yes

– Comcast SMTP Relay

relayhost = [smtp.comcast.net]:587 smtp_sasl_auth_enable = yes smtp_sasl_password_maps = hash:/etc/postfix/smtp_passwd smtp_sasl_security_options = noanonymous smtp_sasl_tls_security_options = noanonymous


I have had the AUTH PLAIN, IMAP, and relay host working today already, but something has broken it.

Also, the messages accepted in the relay never delivered, but they were accepted by a 3rd party, Comcast, relay, which would have delivered the message even if my networking wasn’t correct, I’d assume, no?

Please advise for what you need to assist in troubleshooting.

Thanks!

This is odd. The postconf tool can also be used to configure settings in addition to just viewing them. I would try the following to attempt to change the setting:

sudo postconf -e 'smtpd_sasl_auth_enable = yes'
sudo service postfix reload

and then check if the configuration variable has changed.