Basic questions about One-Click Install WordPress on Ubuntu 12.10


I am new to Digitalocean and VPS hosting.

I am learning to setup and move data for my WordPress blog. I use both methods - first, setting up WordPress from starch ( I followed this tutorial - Second, using one-click install (I am following this tutorial- . The first method- setting WordPress from scratch, works perfectly well, but I am having trouble in one-click installation.

First Question: When I use one-click to feature install WordPress on Ubuntu 12.10, it simply install WordPress, and left me unaware about details such as MySQL Database name, username and password for my newly installed WordPress blog. I also tried to access wp-config.php. file, but I was baffled after seeing that there no information was stored in the file-( Can you help me find these details ?

Second Question: I am also trying to install PHPMyAdmin for database administration and importing old database. I used apt-get install -y phpmyadmin, and I can easily access PHPMyAdmin login page by navigating to http://IP/phpmyadmin ( But I don’t have any idea about the login username and password. Where can I find these details ?

Third Question (not much important): When I execute mysql, sometimes, I encountered this error message- ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: Yes). What cause this error message ? Any idea ?

Note: Software I use - DigitalOcean Console, Putty and WinSCP.

Your help is appreciated.

Thanks Ishank

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

hi Kamal, <br> <br>I tried that but got stuck in safemode. When trying to stop mysql, it gives me this: <br>Since the script you are attempting to invoke has been converted to an <br>Upstart job, you may also use the stop(8) utility, e.g. stop mysql <br>–> this occurs when trying to restart and stop mysql. <br> <br>If im correct, the password is still unchanged and from the beginning i haven’t had access to mysql. i’m using putty, shouldn’t i set any permissions for the ip adress im trying to log on from? Perhaps i’m a bit ahead of my issue now but again, i tried everything, sure its a small setting in the config. <br> <br>

Hi Could anyone give me any direction on how to access mysql without this ERROR 28000? <br>ERROR 1045 (28000): Access denied for user ‘root’@‘localhost’ (using password: YES) <br> <br>I’ve tried every tutorial but dont seem to be able to set a new password in the first place. <br> <br>thanks <br> <br>