Bitcoin node on docker instance fails on various ways, networks and disk errors. What you might recommend to do?

November 13, 2018 896 views
CentOS DigitalOcean Docker

Hey. I’m building a microservice on top of Bitcoin and trying to launch a testnet node. It constantly fails however it works on my desktop. The problem is complicated because I do not have any debug info which allowed me to trace errors. Docker container just stops working and I have not other option as to repeat downloading blockchain which is huge. Or an application inside container (Bitcoin daemon) exits and I can figure out what’s happening only when adding debug level (problem with connection with peers).

I’m close to go on our Google instance and stop working with DO at least if I need blockchain-related applications.

1 Answer

Was your problem solved?
I would love to hear the full story.
And what platfrom will use for the microservice?
I would recommend reading an information about Mobile Go coin https://bitcoinexchangeguide.com/mobilego/. It’s way better than Google play and the App store. I have an app on the platform and revenue I withdraw revenue in bitcoins and purchase other games there in bitcoin as well. Have you ever worked with something like that? Mobile takes 10% of an app revenue and payouts could be recieved in 60 hoursin comparisson to 30% and 60 days on Google.
Hope it helps!

Have another answer? Share your knowledge.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!