Blank page after PHPMyAdmin Installation (Ubuntu, Nginx, HHVM, MariaDB)

January 14, 2015 9.1k views


I have started a new droplet with Ubuntu 14.04, installed Nginx, installed MariaDB, installed HHVM. All confirmed to work at this point.

Then I installed PHPMyAdmin, did the symbolic link and was able to login with root and password. But the next page is blank.

I have no errors in my Nginx log. What did I do wrong?

1 comment
5 Answers

I had the same issue. I checked the HHVM logs and it was complaining about a missing port number. Adding $cfg['Servers'][$i]['port'] = '3306'; to my fixed the problem. You may have to change the port number to the number you are using for your MySql server.

  • After researching this for while thlhotta's solution worked for me. HHVM + PhpMyAdmin

  • This is the solution that worked for me.

    In case anyone is wondering, the file is specific to PhpMyAdmin and not HHVM or nginx. The complete path is /etc/phpmyadmin/ on Ubuntu (and likely other distros). Apologies for the bump, but I'm sure others will run into this issue.

  • Not working for me

  • Seems to work but i get this in my error log

    \nFatal error: Uncaught exception 'Exception' with message 'Port is not numeric' in /usr/share/phpmyadmin/libraries/dbi/mysqli.dbi.lib.php:105\nStack trace:\n#0 /usr/share/phpmyadmin/libraries/dbi/mysqli.dbi.lib.php(105): mysqli_real_connect()\n#1 /usr/share/phpmyadmin/libraries/dbi/mysqli.dbi.lib.php(174): PMA_DBI_real_connect()\n#2 /usr/share/phpmyadmin/libraries/ PMA_DBI_connect()\n#3 /usr/share/phpmyadmin/index.php(11): include()\n#4 {main}

There are some issues with HHVM and Mysqli (the PHP lib used by PHPMyAdmin to connect to MySql). I've seen some varying reports of people getting this to work. Support might potentially be better in the nightly builds.

That would explain alot... :) Thanks for the details!

I tried this issue with no resolution. any ideas why I still face this problem?

not working on my new server, displaying error 500

Have another answer? Share your knowledge.