Browscap problem

Posted December 14, 2013 12k views
I get this error when i run get_browser() function in php: Warning: get_browser(): browscap ini directive not set... I enabled that in php.ini and put file in etc/extra/browscap.ini as i wrote in php.ini, but still doesn't work. Why? I restarted httpd few times.

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Submit an Answer
8 answers
Which php.ini file did you edit? Where is it located?
It's located in /etc/php.ini
Try creating a file with
<?php phpinfo()
in it and browsing to it, do you see your browscap configuration set properly?

If not, try checking for other php.ini files (I'm not really familiar with CentOS so I don't know where everything is exactly):
sudo find / -name php.ini -type f 2>/dev/null
After entering command in terminal, output is /etc/php.ini

phpinfo() at browscap says "no value"... Why?
Are you sure you configured browscap properly in php.ini? What lines did you change/add?
browscap = /etc/extra/browscap.ini

I uncommented that line and added my path.
Help please, i need this function.

Shouldnt it be browscap = “/etc/extra/browscap.ini” ?