Question

Bug report: Copying password from Managed Database connection parameters adds a leading space

Hi, I’ve found a bug in the UI which tripped me up for a few hours today. When you copy the database password from the “Connection Parameters” a leading space will be added in the clipboard. To replicate:

  1. View the cluster details for a DO managed database (in my case Postgres)
  2. In the connection details section select “Connection Parameters” in the dropdown
  3. Next to password click “show”
  4. Double click the password to highlight it, Copy it (using keyboard shortcuts)
  5. Paste it somewhere and a leading space is added to the string

Submit an answer

This textbox defaults to using Markdown to format your answer.

You can type !ref in this text area to quickly search our full set of tutorials, documentation & marketplace offerings and insert the link!

Sign In or Sign Up to Answer

These answers are provided by our Community. If you find them useful, show some love by clicking the heart. If you run into issues leave a comment, or add your own answer to help others.

Want to learn more? Join the DigitalOcean Community!

Join our DigitalOcean community of over a million developers for free! Get help and share knowledge in Q&A, subscribe to topics of interest, and get courses and tools that will help you grow as a developer and scale your project or business.

Hi @TinySeaGreenDinghy,

I did not see any space getting added while copying the password from the connection details on the database page. I have tried pasting the password in the terminal, text editor but did not see space getting added.

Regards, Rajkishore